Content Cloud issues are being investigated

Incident Report for Purple Publish

Postmortem

For a limited period (12:00 CEST - 13:45 CEST), some content requests temporarily ran on a slower processing path instead of our optimized search system. This caused higher-than-normal response times and increased load for the affected requests.

We identified the cause — an internal configuration that, under certain timing conditions, kept requests on the slower path longer than intended — and have corrected it. As an immediate measure we restored the affected requests to the optimized path, and we've added a safeguard so the situation cannot recur. Performance is back to normal.

Posted Jun 04, 2026 - 14:05 CEST

Resolved

The performance issues in Purple Content Cloud have been fully resolved, and the service is operating at full capacity. We thank you for your patience during this time.
Posted Jun 04, 2026 - 14:05 CEST

Monitoring

We are currently monitoring the performance of Purple Content Cloud after implementing improvements to ensure that it meets our standards.
Posted Jun 04, 2026 - 13:47 CEST

Investigating

We are aware of performance issues affecting the Purple Content Cloud and are investigating the root causes. More information will be provided as our investigation continues.
Posted Jun 04, 2026 - 13:46 CEST
This incident affected: Purple Delivery (Catalog API) and Purple Experience.