Investigating issues with Purple Hub

Incident Report for Purple Publish

Postmortem

Summary

Our system experienced performance degradation due to an expensive database query that caused high load on the database. This resulted in slow or unresponsive behavior in our hubs.

Impact

The high database load affected the availability and responsiveness of our Hubs for a short period which caused slow loading times and failed requests. The issue was partially mitigated by our autoscaling mechanism, which helped stabilize the system temporarily.

Resolution

After identifying the problematic query as the root cause, it was promptly removed from the system. This resolved the performance issues and restored normal operation. To prevent recurrence, we are implementing improved monitoring to detect similar issues earlier and adjusting system configurations to reduce the impact of expensive queries.

Posted Jul 17, 2025 - 14:01 CEST

Resolved

This incident has been resolved.
Posted Jul 17, 2025 - 09:57 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2025 - 09:39 CEST

Identified

We have identified the root cause of the issue and have deployed a fix. The Purple Hub can already be used, but does still suffer from degraded performance. We are continuing to monitor the situation.
Posted Jul 17, 2025 - 09:28 CEST

Update

We have noticed a disruption in Purple Hub, our CMS for editors, and are currently investigating the cause. We appreciate your patience as we work to resolve this as quickly as possible.
Posted Jul 17, 2025 - 09:22 CEST

Investigating

We are currently investigating this issue.
Posted Jul 17, 2025 - 09:22 CEST
This incident affected: Purple Hub (c02).